AWS Outage: All My Well Services Unavailable

Incident Report for My Well Giving

Resolved

This incident has been resolved. AWS services have been restored.
Posted Oct 20, 2025 - 14:27 EDT

Monitoring

AWS is currently experiencing outages that impact all My Well Services.
Posted Oct 20, 2025 - 11:09 EDT
This incident affected: AWS lambda-us-east-1.